createrepo-c_0.16.1.bb 1.2 KB

12345678910111213141516171819202122232425262728293031323334
  1. DESCRIPTION = "C implementation of createrepo."
  2. HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
  3. LICENSE = "GPLv2"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  5. SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
  6. file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
  7. "
  8. SRCREV = "634141eaefe0cc87466dfb91b07b64facce4384b"
  9. S = "${WORKDIR}/git"
  10. DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
  11. DEPENDS_append_class-native = " file-replacement-native"
  12. inherit cmake pkgconfig bash-completion distutils3-base
  13. EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF"
  14. BBCLASSEXTEND = "native nativesdk"
  15. # Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
  16. do_install_append_class-native() {
  17. create_wrapper ${D}/${bindir}/createrepo_c \
  18. RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
  19. }
  20. do_install_append_class-nativesdk() {
  21. create_wrapper ${D}/${bindir}/createrepo_c \
  22. RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm
  23. rm -rf ${D}/etc
  24. }