bison_3.7.3.bb 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. SUMMARY = "GNU Project parser generator (yacc replacement)"
  2. DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
  3. an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
  4. grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
  5. little trouble."
  6. HOMEPAGE = "http://www.gnu.org/software/bison/"
  7. LICENSE = "GPLv3"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
  9. SECTION = "devel"
  10. DEPENDS = "bison-native flex-native"
  11. SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
  12. file://add-with-bisonlocaledir.patch \
  13. "
  14. SRC_URI[sha256sum] = "88d9e36856b004c0887a12ba00ea3c47db388519629483dd8c3fce9694d4da6f"
  15. # No point in hardcoding path to m4, just use PATH
  16. EXTRA_OECONF += "M4=m4"
  17. inherit autotools gettext texinfo
  18. # The automatic m4 path detection gets confused, so force the right value
  19. acpaths = "-I ./m4"
  20. do_compile_prepend() {
  21. for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
  22. }
  23. do_install_append_class-native() {
  24. create_wrapper ${D}/${bindir}/bison \
  25. BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
  26. }
  27. do_install_append_class-nativesdk() {
  28. create_wrapper ${D}/${bindir}/bison \
  29. BISON_PKGDATADIR=${datadir}/bison
  30. }
  31. BBCLASSEXTEND = "native nativesdk"