systemd-bootconf_1.00.bb 718 B

1234567891011121314151617181920212223242526272829303132
  1. LICENSE = "MIT"
  2. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
  3. SUMMARY = "Basic systemd-boot configuration files"
  4. RPROVIDES_${PN} += "virtual/systemd-bootconf"
  5. PACKAGE_ARCH = "${MACHINE_ARCH}"
  6. inherit systemd-boot-cfg
  7. S = "${WORKDIR}"
  8. LABELS = "boot"
  9. ROOT ?= "root=/dev/sda2"
  10. APPEND_append = " ${ROOT}"
  11. python do_configure() {
  12. bb.build.exec_func('build_efi_cfg', d)
  13. }
  14. do_configure[vardeps] += "APPEND"
  15. do_install() {
  16. install -d ${D}/boot
  17. install -d ${D}/boot/loader
  18. install -d ${D}/boot/loader/entries
  19. install loader.conf ${D}/boot/loader/
  20. rm loader.conf
  21. install *.conf ${D}/boot/loader/entries/
  22. }
  23. FILES_${PN} = "/boot/loader/* /boot/loader/entries/*"