ovmf-shell-image.bb 679 B

1234567891011121314151617181920
  1. DESCRIPTION = "boot image with UEFI shell and tools"
  2. # For this image recipe, only the wic format with a
  3. # single vfat partition makes sense. Because we have no
  4. # boot loader and no rootfs partition, not additional
  5. # tools are needed for this .wks file.
  6. IMAGE_FSTYPES_forcevariable = 'wic'
  7. WKS_FILE = "ovmf/ovmf-shell-image.wks"
  8. WKS_FILE_DEPENDS = ""
  9. inherit image
  10. # We want a minimal image with just ovmf-shell-efi unpacked in it. We
  11. # avoid installing unnecessary stuff as much as possible, but some
  12. # things still get through and need to be removed.
  13. PACKAGE_INSTALL = "ovmf-shell-efi"
  14. LINGUAS_INSTALL = ""
  15. do_image () {
  16. rm -rf `ls -d ${IMAGE_ROOTFS}/* | grep -v efi`
  17. }