newlib_3.3.0.bb 571 B

1234567891011121314151617181920
  1. require newlib.inc
  2. PROVIDES += "virtual/libc virtual/libiconv virtual/libintl"
  3. do_configure() {
  4. export CC_FOR_TARGET="${CC}"
  5. ${S}/configure ${EXTRA_OECONF}
  6. }
  7. do_install_append() {
  8. # Move include files and libs to default directories so they can be picked up later
  9. mv -v ${D}${prefix}/${TARGET_SYS}/lib ${D}${libdir}
  10. mv -v ${D}${prefix}/${TARGET_SYS}/include ${D}${includedir}
  11. # Remove original directory
  12. rmdir ${D}${prefix}/${TARGET_SYS}
  13. }
  14. # No rpm package is actually created but -dev depends on it, avoid dnf error
  15. RDEPENDS_${PN}-dev_libc-newlib = ""