libgloss_3.3.0.bb 858 B

123456789101112131415161718192021222324252627282930313233
  1. require newlib.inc
  2. DEPENDS += "newlib"
  3. FILESEXTRAPATHS_prepend := "${THISDIR}/libgloss:"
  4. SRC_URI_append_powerpc = " file://fix-rs6000-crt0.patch"
  5. SRC_URI_append_arm = " file://fix_makefile_include_arm_h.patch"
  6. do_configure() {
  7. ${S}/libgloss/configure ${EXTRA_OECONF}
  8. }
  9. do_install_prepend() {
  10. # install doesn't create this itself, avoid install error
  11. install -d ${D}${prefix}/${TARGET_SYS}/lib
  12. }
  13. do_install_append() {
  14. # Move libs to default directories so they can be picked up later
  15. install -d ${D}${libdir}
  16. mv -v ${D}${prefix}/${TARGET_SYS}/lib/* ${D}${libdir}
  17. # Remove original directory
  18. rmdir -p --ignore-fail-on-non-empty ${D}${prefix}/${TARGET_SYS}/lib
  19. }
  20. # Split packages correctly
  21. FILES_${PN} += "${libdir}/*.ld ${libdir}/*.specs"
  22. FILES_${PN}-dev += "${libdir}/cpu-init/*"
  23. INHIBIT_PACKAGE_STRIP = "1"
  24. INHIBIT_PACKAGE_DEBUG_SPLIT = "1"