wic-tools.bb 928 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "A meta recipe to build native tools used by wic."
  2. LICENSE = "MIT"
  3. DEPENDS = "\
  4. parted-native syslinux-native gptfdisk-native dosfstools-native \
  5. mtools-native bmap-tools-native grub-native cdrtools-native \
  6. btrfs-tools-native squashfs-tools-native pseudo-native \
  7. e2fsprogs-native util-linux-native tar-native\
  8. "
  9. DEPENDS_append_x86 = " syslinux grub-efi systemd-boot"
  10. DEPENDS_append_x86-64 = " syslinux grub-efi systemd-boot"
  11. DEPENDS_append_x86-x32 = " syslinux grub-efi"
  12. INHIBIT_DEFAULT_DEPS = "1"
  13. inherit nopackages
  14. # The sysroot of wic-tools is needed for wic, but if rm_work is enabled, it will
  15. # be removed before wic has a chance to use it, hence the exclusion below.
  16. RM_WORK_EXCLUDE += "${PN}"
  17. python do_build_sysroot () {
  18. bb.build.exec_func("extend_recipe_sysroot", d)
  19. }
  20. addtask do_build_sysroot after do_prepare_recipe_sysroot before do_build