buildtools-extended-tarball.bb 1.2 KB

123456789101112131415161718192021222324252627282930313233343536
  1. require recipes-core/meta/buildtools-tarball.bb
  2. DESCRIPTION = "SDK type target for building a standalone tarball containing build-essentials, python3, chrpath, \
  3. make, git and tar. The tarball can be used to run bitbake builds on systems which don't meet the \
  4. usual version requirements and have ancient compilers."
  5. SUMMARY = "Standalone tarball for running builds on systems with inadequate software and ancient compilers"
  6. LICENSE = "MIT"
  7. # Add nativesdk equivalent of build-essentials
  8. TOOLCHAIN_HOST_TASK += "\
  9. nativesdk-automake \
  10. nativesdk-autoconf \
  11. nativesdk-binutils \
  12. nativesdk-binutils-symlinks \
  13. nativesdk-cpp \
  14. nativesdk-cpp-symlinks \
  15. nativesdk-gcc \
  16. nativesdk-gcc-symlinks \
  17. nativesdk-g++ \
  18. nativesdk-g++-symlinks \
  19. nativesdk-gettext \
  20. nativesdk-libatomic \
  21. nativesdk-libgcc \
  22. nativesdk-libgomp-dev \
  23. nativesdk-libstdc++ \
  24. nativesdk-libstdc++-dev \
  25. nativesdk-libstdc++-staticdev \
  26. nativesdk-libtool \
  27. nativesdk-pkgconfig \
  28. nativesdk-glibc-utils \
  29. nativesdk-libxcrypt-dev \
  30. "
  31. TOOLCHAIN_OUTPUTNAME = "${SDK_ARCH}-buildtools-extended-nativesdk-standalone-${DISTRO_VERSION}"
  32. SDK_TITLE = "Extended Build tools"