init-system-helpers_1.58.bb 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. SUMMARY = "helper tools for all init systems"
  2. DESCRIPTION = "This package contains helper tools that are necessary for switching between \
  3. the various init systems that Debian contains (e. g. sysvinit or \
  4. systemd). An example is deb-systemd-helper, a script that enables systemd unit \
  5. files without depending on a running systemd. \
  6. \
  7. It also includes the \"service\", \"invoke-rc.d\", and \"update-rc.d\" scripts which \
  8. provide an abstraction for enabling, disabling, starting, and stopping \
  9. services for all supported Debian init systems as specified by the policy. \
  10. \
  11. While this package is maintained by pkg-systemd-maintainers, it is NOT \
  12. specific to systemd at all. Maintainers of other init systems are welcome to \
  13. include their helpers in this package."
  14. HOMEPAGE = "https://salsa.debian.org/debian/init-system-helpers"
  15. SECTION = "base"
  16. LICENSE = "BSD-3-Clause & GPLv2"
  17. LIC_FILES_CHKSUM = "file://debian/copyright;md5=ee2b1830fcfead84d07bc060ec43e072"
  18. SRCREV = "6a1860c6f5ad295af605ddf588933544e7c24ce1"
  19. SRC_URI = "git://salsa.debian.org/debian/init-system-helpers.git;protocol=https"
  20. S = "${WORKDIR}/git"
  21. do_configure[noexec] = "1"
  22. do_compile[noexec] = "1"
  23. do_install() {
  24. install -d -m 0755 ${D}${sbindir}
  25. install -m 0755 ${S}/script/invoke-rc.d ${D}${sbindir}
  26. install -m 0755 ${S}/script/service ${D}${sbindir}
  27. }
  28. PACKAGES += "${PN}-invoke-rc.d ${PN}-service"
  29. FILES_${PN} = ""
  30. FILES_${PN}-invoke-rc.d = "${sbindir}/invoke-rc.d"
  31. FILES_${PN}-service = "${sbindir}/service"
  32. ALLOW_EMPTY_${PN} = "1"
  33. RRECOMMENDS_${PN} += "${PN}-invoke-rc.d ${PN}-service"