initramfs-module-install_1.0.bb 739 B

1234567891011121314151617181920212223
  1. SUMMARY = "initramfs-framework module for installation option"
  2. LICENSE = "MIT"
  3. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
  4. RDEPENDS_${PN} = "initramfs-framework-base grub parted e2fsprogs-mke2fs util-linux-blkid ${VIRTUAL-RUNTIME_base-utils}"
  5. RRECOMMENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog}"
  6. # The same restriction as grub
  7. COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*)-(linux.*|freebsd.*)'
  8. COMPATIBLE_HOST_armv7a = 'null'
  9. COMPATIBLE_HOST_armv7ve = 'null'
  10. PR = "r1"
  11. SRC_URI = "file://init-install.sh"
  12. S = "${WORKDIR}"
  13. do_install() {
  14. install -d ${D}/init.d
  15. install -m 0755 ${WORKDIR}/init-install.sh ${D}/init.d/install.sh
  16. }
  17. FILES_${PN} = "/init.d/install.sh"