glib-2.0_2.66.2.bb 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. require glib.inc
  2. PE = "1"
  3. SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
  4. SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
  5. file://run-ptest \
  6. file://0001-Fix-DATADIRNAME-on-uclibc-Linux.patch \
  7. file://Enable-more-tests-while-cross-compiling.patch \
  8. file://0001-Remove-the-warning-about-deprecated-paths-in-schemas.patch \
  9. file://0001-Install-gio-querymodules-as-libexec_PROGRAM.patch \
  10. file://0001-Do-not-ignore-return-value-of-write.patch \
  11. file://0010-Do-not-hardcode-python-path-into-various-tools.patch \
  12. file://0001-Set-host_machine-correctly-when-building-with-mingw3.patch \
  13. file://0001-Do-not-write-bindir-into-pkg-config-files.patch \
  14. file://0001-meson-Run-atomics-test-on-clang-as-well.patch \
  15. file://0001-gio-tests-resources.c-comment-out-a-build-host-only-.patch \
  16. "
  17. SRC_URI_append_class-native = " file://relocate-modules.patch"
  18. SRC_URI[sha256sum] = "ec390bed4e8dd0f89e918f385e8d4cfd7470b1ef7c1ce93ec5c4fc6e3c6a17c4"
  19. # Find any meson cross files in FILESPATH that are relevant for the current
  20. # build (using siteinfo) and add them to EXTRA_OEMESON.
  21. inherit siteinfo
  22. def find_meson_cross_files(d):
  23. if bb.data.inherits_class('native', d):
  24. return ""
  25. corebase = d.getVar("COREBASE")
  26. import collections
  27. sitedata = siteinfo_data(d)
  28. # filename -> found
  29. files = collections.OrderedDict()
  30. for path in d.getVar("FILESPATH").split(":"):
  31. for element in sitedata:
  32. filename = os.path.normpath(os.path.join(path, "meson.cross.d", element))
  33. files[filename.replace(corebase, "${COREBASE}")] = os.path.exists(filename)
  34. items = ["--cross-file=" + k for k,v in files.items() if v]
  35. d.appendVar("EXTRA_OEMESON", " " + " ".join(items))
  36. items = ["%s:%s" % (k, "True" if v else "False") for k,v in files.items()]
  37. d.appendVarFlag("do_configure", "file-checksums", " " + " ".join(items))
  38. python () {
  39. find_meson_cross_files(d)
  40. }