ppp-dialin_0.1.bb 771 B

123456789101112131415161718192021222324252627
  1. SUMMARY = "Enables PPP dial-in through a serial connection"
  2. SECTION = "console/network"
  3. DEPENDS = "ppp"
  4. RDEPENDS_${PN} = "ppp"
  5. PR = "r8"
  6. LICENSE = "MIT"
  7. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
  8. SRC_URI = "file://host-peer \
  9. file://ppp-dialin"
  10. inherit allarch useradd
  11. S = "${WORKDIR}"
  12. do_install() {
  13. install -d ${D}${sysconfdir}/ppp/peers
  14. install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
  15. install -d ${D}${sbindir}
  16. install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
  17. }
  18. USERADD_PACKAGES = "${PN}"
  19. USERADD_PARAM_${PN} = "--system --home /dev/null \
  20. --no-create-home --shell ${sbindir}/ppp-dialin \
  21. --no-user-group --gid nogroup ppp"