libnss-mdns_0.14.1.bb 891 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. SUMMARY = "Name Service Switch module for Multicast DNS (zeroconf) name resolution"
  2. HOMEPAGE = "https://github.com/lathiat/nss-mdns"
  3. SECTION = "libs"
  4. LICENSE = "LGPLv2.1+"
  5. LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
  6. DEPENDS = "avahi"
  7. SRC_URI = "git://github.com/lathiat/nss-mdns \
  8. "
  9. SRCREV = "41c9c5e78f287ed4b41ac438c1873fa71bfa70ae"
  10. S = "${WORKDIR}/git"
  11. inherit autotools pkgconfig
  12. COMPATIBLE_HOST_libc-musl = 'null'
  13. EXTRA_OECONF = "--libdir=${base_libdir}"
  14. RDEPENDS_${PN} = "avahi-daemon"
  15. pkg_postinst_${PN} () {
  16. sed '
  17. /^hosts:/ !b
  18. /\<mdns\(4\|6\)\?\(_minimal\)\?\>/ b
  19. s/\([[:blank:]]\+\)dns\>/\1mdns4_minimal [NOTFOUND=return] dns/g
  20. ' -i $D${sysconfdir}/nsswitch.conf
  21. }
  22. pkg_prerm_${PN} () {
  23. sed '
  24. /^hosts:/ !b
  25. s/[[:blank:]]\+mdns\(4\|6\)\?\(_minimal\( \[NOTFOUND=return\]\)\?\)\?//g
  26. ' -i $D${sysconfdir}/nsswitch.conf
  27. }