formfactor_0.0.bb 811 B

1234567891011121314151617181920212223
  1. SUMMARY = "Device formfactor information"
  2. DESCRIPTION = "A formfactor configuration file provides information about the \
  3. target hardware for which the image is being built and information that the \
  4. build system cannot obtain from other sources such as the kernel."
  5. SECTION = "base"
  6. LICENSE = "MIT"
  7. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
  8. PR = "r45"
  9. SRC_URI = "file://config file://machconfig"
  10. S = "${WORKDIR}"
  11. PACKAGE_ARCH = "${MACHINE_ARCH}"
  12. INHIBIT_DEFAULT_DEPS = "1"
  13. do_install() {
  14. # Install file only if it has contents
  15. install -d ${D}${sysconfdir}/formfactor/
  16. install -m 0644 ${S}/config ${D}${sysconfdir}/formfactor/
  17. if [ -s "${S}/machconfig" ]; then
  18. install -m 0644 ${S}/machconfig ${D}${sysconfdir}/formfactor/
  19. fi
  20. }