toolchain-scripts-base.bbclass 416 B

1234567891011
  1. #This function create a version information file
  2. toolchain_create_sdk_version () {
  3. local versionfile=$1
  4. rm -f $versionfile
  5. touch $versionfile
  6. echo 'Distro: ${DISTRO}' >> $versionfile
  7. echo 'Distro Version: ${DISTRO_VERSION}' >> $versionfile
  8. echo 'Metadata Revision: ${METADATA_REVISION}' >> $versionfile
  9. echo 'Timestamp: ${DATETIME}' >> $versionfile
  10. }
  11. toolchain_create_sdk_version[vardepsexclude] = "DATETIME"