systemd-boot.bbclass 1.1 KB

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright (C) 2016 Intel Corporation
  2. #
  3. # Released under the MIT license (see COPYING.MIT)
  4. # systemd-boot.bbclass - The "systemd-boot" is essentially the gummiboot merged into systemd.
  5. # The original standalone gummiboot project is dead without any more
  6. # maintenance.
  7. #
  8. # Set EFI_PROVIDER = "systemd-boot" to use systemd-boot on your live images instead of grub-efi
  9. # (images built by image-live.bbclass)
  10. do_bootimg[depends] += "${MLPREFIX}systemd-boot:do_deploy"
  11. require conf/image-uefi.conf
  12. # Need UUID utility code.
  13. inherit fs-uuid
  14. efi_populate() {
  15. efi_populate_common "$1" systemd
  16. # systemd-boot requires these paths for configuration files
  17. # they are not customizable so no point in new vars
  18. install -d ${DEST}/loader
  19. install -d ${DEST}/loader/entries
  20. install -m 0644 ${SYSTEMD_BOOT_CFG} ${DEST}/loader/loader.conf
  21. for i in ${SYSTEMD_BOOT_ENTRIES}; do
  22. install -m 0644 ${i} ${DEST}/loader/entries
  23. done
  24. }
  25. efi_iso_populate_append() {
  26. cp -r $iso_dir/loader ${EFIIMGDIR}
  27. }
  28. inherit systemd-boot-cfg