python3native.bbclass 839 B

1234567891011121314151617181920212223242526
  1. inherit python3-dir
  2. PYTHON="${STAGING_BINDIR_NATIVE}/python3-native/python3"
  3. EXTRANATIVEPATH += "python3-native"
  4. DEPENDS_append = " python3-native "
  5. # python-config and other scripts are using distutils modules
  6. # which we patch to access these variables
  7. export STAGING_INCDIR
  8. export STAGING_LIBDIR
  9. # Packages can use
  10. # find_package(PythonInterp REQUIRED)
  11. # find_package(PythonLibs REQUIRED)
  12. # which ends up using libs/includes from build host
  13. # Therefore pre-empt that effort
  14. export PYTHON_LIBRARY="${STAGING_LIBDIR}/lib${PYTHON_DIR}${PYTHON_ABI}.so"
  15. export PYTHON_INCLUDE_DIR="${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}"
  16. export _PYTHON_SYSCONFIGDATA_NAME="_sysconfigdata"
  17. # suppress host user's site-packages dirs.
  18. export PYTHONNOUSERSITE = "1"
  19. # autoconf macros will use their internal default preference otherwise
  20. export PYTHON