gettext.bbclass 864 B

12345678910111213141516171819202122
  1. def gettext_dependencies(d):
  2. if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
  3. return ""
  4. if d.getVar('USE_NLS') == 'no':
  5. return "gettext-minimal-native"
  6. return "gettext-native"
  7. def gettext_oeconf(d):
  8. if d.getVar('USE_NLS') == 'no':
  9. return '--disable-nls'
  10. # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
  11. if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
  12. return '--disable-nls'
  13. return "--enable-nls"
  14. BASEDEPENDS_append = " ${@gettext_dependencies(d)}"
  15. EXTRA_OECONF_append = " ${@gettext_oeconf(d)}"
  16. # Without this, msgfmt from gettext-native will not find ITS files
  17. # provided by target recipes (for example, polkit.its).
  18. GETTEXTDATADIRS_append_class-target = ":${STAGING_DATADIR}/gettext"
  19. export GETTEXTDATADIRS