dos2unix.bbclass 518 B

1234567891011121314
  1. # Class for use to convert all CRLF line terminators to LF
  2. # provided that some projects are being developed/maintained
  3. # on Windows so they have different line terminators(CRLF) vs
  4. # on Linux(LF), which can cause annoying patching errors during
  5. # git push/checkout processes.
  6. do_convert_crlf_to_lf[depends] += "dos2unix-native:do_populate_sysroot"
  7. # Convert CRLF line terminators to LF
  8. do_convert_crlf_to_lf () {
  9. find ${S} -type f -exec dos2unix {} \;
  10. }
  11. addtask convert_crlf_to_lf after do_unpack before do_patch