systemd-boot_232.bb 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. require recipes-core/systemd/systemd.inc
  2. DEPENDS = "intltool-native libcap util-linux gnu-efi"
  3. SRC_URI += "file://0001-use-lnr-wrapper-instead-of-looking-for-relative-opti.patch"
  4. inherit autotools pkgconfig gettext
  5. inherit deploy
  6. # Man pages are packaged through the main systemd recipe
  7. EXTRA_OECONF = " --enable-gnuefi \
  8. --with-efi-includedir=${STAGING_INCDIR} \
  9. --with-efi-ldsdir=${STAGING_LIBDIR} \
  10. --with-efi-libdir=${STAGING_LIBDIR} \
  11. --disable-manpages \
  12. "
  13. # Imported from the old gummiboot recipe
  14. TUNE_CCARGS_remove = "-mfpmath=sse"
  15. COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
  16. do_compile() {
  17. SYSTEMD_BOOT_EFI_ARCH="ia32"
  18. if [ "${TARGET_ARCH}" = "x86_64" ]; then
  19. SYSTEMD_BOOT_EFI_ARCH="x64"
  20. fi
  21. oe_runmake systemd-boot${SYSTEMD_BOOT_EFI_ARCH}.efi
  22. }
  23. do_install() {
  24. # Bypass systemd installation with a NOP
  25. :
  26. }
  27. do_deploy () {
  28. install ${B}/systemd-boot*.efi ${DEPLOYDIR}
  29. }
  30. addtask deploy before do_build after do_compile