fs-uuid.bbclass 1011 B

123456789101112131415161718192021222324
  1. # Extract UUID from ${ROOTFS}, which must have been built
  2. # by the time that this function gets called. Only works
  3. # on ext file systems and depends on tune2fs.
  4. def get_rootfs_uuid(d):
  5. import subprocess
  6. rootfs = d.getVar('ROOTFS')
  7. output = subprocess.check_output(['tune2fs', '-l', rootfs])
  8. for line in output.split('\n'):
  9. if line.startswith('Filesystem UUID:'):
  10. uuid = line.split()[-1]
  11. bb.note('UUID of %s: %s' % (rootfs, uuid))
  12. return uuid
  13. bb.fatal('Could not determine filesystem UUID of %s' % rootfs)
  14. # Replace the special <<uuid-of-rootfs>> inside a string (like the
  15. # root= APPEND string in a syslinux.cfg or systemd-boot entry) with the
  16. # actual UUID of the rootfs. Does nothing if the special string
  17. # is not used.
  18. def replace_rootfs_uuid(d, string):
  19. UUID_PLACEHOLDER = '<<uuid-of-rootfs>>'
  20. if UUID_PLACEHOLDER in string:
  21. uuid = get_rootfs_uuid(d)
  22. string = string.replace(UUID_PLACEHOLDER, uuid)
  23. return string