shadow-sysroot_4.6.bb 1001 B

12345678910111213141516171819202122232425262728293031
  1. SUMMARY = "Shadow utils requirements for useradd.bbclass"
  2. HOMEPAGE = "http://github.com/shadow-maint/shadow"
  3. BUGTRACKER = "http://github.com/shadow-maint/shadow/issues"
  4. SECTION = "base utils"
  5. LICENSE = "BSD | Artistic-1.0"
  6. LIC_FILES_CHKSUM = "file://login.defs_shadow-sysroot;md5=25e2f2de4dfc8f966ac5cdfce45cd7d5"
  7. DEPENDS = "base-passwd"
  8. PR = "r3"
  9. # The sole purpose of this recipe is to provide the /etc/login.defs
  10. # file for the target sysroot - needed so the shadow-native utilities
  11. # can add custom users/groups for recipes that use inherit useradd.
  12. SRC_URI = "file://login.defs_shadow-sysroot"
  13. S = "${WORKDIR}"
  14. do_install() {
  15. install -d ${D}${sysconfdir}
  16. install -p -m 644 ${S}/login.defs_shadow-sysroot ${D}${sysconfdir}/login.defs
  17. }
  18. SYSROOT_DIRS += "${sysconfdir}"
  19. # don't create any packages
  20. # otherwise: dbus-dev depends on shadow-sysroot-dev which depends on shadow-sysroot
  21. # and this has another copy of /etc/login.defs already provided by shadow
  22. PACKAGES = ""
  23. inherit nopackages