rsync_3.2.3.bb 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. SUMMARY = "File synchronization tool"
  2. HOMEPAGE = "http://rsync.samba.org/"
  3. BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
  4. SECTION = "console/network"
  5. # GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
  6. # Includes opennsh and xxhash dynamic link exception
  7. LICENSE = "GPLv3+"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=9e5a4f9b3a253d51520617aa54f8eb26"
  9. DEPENDS = "popt"
  10. SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
  11. file://rsyncd.conf \
  12. file://makefile-no-rebuild.patch \
  13. "
  14. SRC_URI[sha256sum] = "becc3c504ceea499f4167a260040ccf4d9f2ef9499ad5683c179a697146ce50e"
  15. # -16548 required for v3.1.3pre1. Already in v3.1.3.
  16. CVE_CHECK_WHITELIST += " CVE-2017-16548 "
  17. inherit autotools-brokensep
  18. PACKAGECONFIG ??= "acl attr \
  19. ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
  20. "
  21. PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
  22. PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
  23. PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
  24. PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4"
  25. PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
  26. PACKAGECONFIG[xxhash] = "--enable-xxhash,--disable-xxhash,xxhash"
  27. PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
  28. # By default, if crosscompiling, rsync disables a number of
  29. # capabilities, hardlinking symlinks and special files (i.e. devices)
  30. CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
  31. EXTRA_OEMAKE = 'STRIP=""'
  32. EXTRA_OECONF = "--disable-simd --disable-md2man --disable-asm"
  33. # rsync 3.0 uses configure.sh instead of configure, and
  34. # makefile checks the existence of configure.sh
  35. do_configure_prepend () {
  36. rm -f ${S}/configure ${S}/configure.sh
  37. }
  38. do_configure_append () {
  39. cp -f ${S}/configure ${S}/configure.sh
  40. }
  41. do_install_append() {
  42. install -d ${D}${sysconfdir}
  43. install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
  44. }
  45. BBCLASSEXTEND = "native nativesdk"