typecheck.bbclass 315 B

123456789101112
  1. # Check types of bitbake configuration variables
  2. #
  3. # See oe.types for details.
  4. python check_types() {
  5. import oe.types
  6. for key in e.data.keys():
  7. if e.data.getVarFlag(key, "type"):
  8. oe.data.typed_value(key, e.data)
  9. }
  10. addhandler check_types
  11. check_types[eventmask] = "bb.event.ConfigParsed"