core-image.bbclass 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. # Common code for generating core reference images
  2. #
  3. # Copyright (C) 2007-2011 Linux Foundation
  4. # IMAGE_FEATURES control content of the core reference images
  5. #
  6. # By default we install packagegroup-core-boot and packagegroup-base-extended packages;
  7. # this gives us working (console only) rootfs.
  8. #
  9. # Available IMAGE_FEATURES:
  10. #
  11. # - x11 - X server
  12. # - x11-base - X server with minimal environment
  13. # - x11-sato - OpenedHand Sato environment
  14. # - tools-debug - debugging tools
  15. # - eclipse-debug - Eclipse remote debugging support
  16. # - tools-profile - profiling tools
  17. # - tools-testapps - tools usable to make some device tests
  18. # - tools-sdk - SDK (C/C++ compiler, autotools, etc.)
  19. # - nfs-server - NFS server
  20. # - nfs-client - NFS client
  21. # - ssh-server-dropbear - SSH server (dropbear)
  22. # - ssh-server-openssh - SSH server (openssh)
  23. # - hwcodecs - Install hardware acceleration codecs
  24. # - package-management - installs package management tools and preserves the package manager database
  25. # - debug-tweaks - makes an image suitable for development, e.g. allowing passwordless root logins
  26. # - empty-root-password
  27. # - allow-empty-password
  28. # - allow-root-login
  29. # - post-install-logging
  30. # - dev-pkgs - development packages (headers, etc.) for all installed packages in the rootfs
  31. # - dbg-pkgs - debug symbol packages for all installed packages in the rootfs
  32. # - doc-pkgs - documentation packages for all installed packages in the rootfs
  33. # - bash-completion-pkgs - bash-completion packages for recipes using bash-completion bbclass
  34. # - ptest-pkgs - ptest packages for all ptest-enabled recipes
  35. # - read-only-rootfs - tweaks an image to support read-only rootfs
  36. # - stateless-rootfs - systemctl-native not run, image populated by systemd at runtime
  37. # - splash - bootup splash screen
  38. #
  39. FEATURE_PACKAGES_x11 = "packagegroup-core-x11"
  40. FEATURE_PACKAGES_x11-base = "packagegroup-core-x11-base"
  41. FEATURE_PACKAGES_x11-sato = "packagegroup-core-x11-sato"
  42. FEATURE_PACKAGES_tools-debug = "packagegroup-core-tools-debug"
  43. FEATURE_PACKAGES_eclipse-debug = "packagegroup-core-eclipse-debug"
  44. FEATURE_PACKAGES_tools-profile = "packagegroup-core-tools-profile"
  45. FEATURE_PACKAGES_tools-testapps = "packagegroup-core-tools-testapps"
  46. FEATURE_PACKAGES_tools-sdk = "packagegroup-core-sdk packagegroup-core-standalone-sdk-target"
  47. FEATURE_PACKAGES_nfs-server = "packagegroup-core-nfs-server"
  48. FEATURE_PACKAGES_nfs-client = "packagegroup-core-nfs-client"
  49. FEATURE_PACKAGES_ssh-server-dropbear = "packagegroup-core-ssh-dropbear"
  50. FEATURE_PACKAGES_ssh-server-openssh = "packagegroup-core-ssh-openssh"
  51. FEATURE_PACKAGES_hwcodecs = "${MACHINE_HWCODECS}"
  52. # IMAGE_FEATURES_REPLACES_foo = 'bar1 bar2'
  53. # Including image feature foo would replace the image features bar1 and bar2
  54. IMAGE_FEATURES_REPLACES_ssh-server-openssh = "ssh-server-dropbear"
  55. # IMAGE_FEATURES_CONFLICTS_foo = 'bar1 bar2'
  56. # An error exception would be raised if both image features foo and bar1(or bar2) are included
  57. MACHINE_HWCODECS ??= ""
  58. CORE_IMAGE_BASE_INSTALL = '\
  59. packagegroup-core-boot \
  60. packagegroup-base-extended \
  61. \
  62. ${CORE_IMAGE_EXTRA_INSTALL} \
  63. '
  64. CORE_IMAGE_EXTRA_INSTALL ?= ""
  65. IMAGE_INSTALL ?= "${CORE_IMAGE_BASE_INSTALL}"
  66. inherit image