libbsd_0.10.0.bb 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright (C) 2013 Khem Raj <raj.khem@gmail.com>
  2. # Released under the MIT license (see COPYING.MIT for the terms)
  3. SUMMARY = "Library of utility functions from BSD systems"
  4. DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \
  5. and lacking on others like GNU systems, thus making it easier to port \
  6. projects with strong BSD origins, without needing to embed the same \
  7. code over and over again on each project."
  8. HOMEPAGE = "https://libbsd.freedesktop.org/wiki/"
  9. # There seems to be more licenses used in the code, I don't think we want to list them all here, complete list:
  10. # OE @ ~/projects/libbsd $ grep ^License: COPYING | sort -u
  11. # License: BSD-2-clause
  12. # License: BSD-2-clause-NetBSD
  13. # License: BSD-2-clause-author
  14. # License: BSD-2-clause-verbatim
  15. # License: BSD-3-clause
  16. # License: BSD-3-clause-author
  17. # License: BSD-3-clause-John-Birrell
  18. # License: BSD-3-clause-Regents
  19. # License: BSD-4-clause-Christopher-G-Demetriou
  20. # License: BSD-4-clause-Niels-Provos
  21. # License: BSD-5-clause-Peter-Wemm
  22. # License: Beerware
  23. # License: Expat
  24. # License: ISC
  25. # License: ISC-Original
  26. # License: public-domain
  27. # License: public-domain-Colin-Plumb
  28. LICENSE = "BSD-4-Clause & ISC & PD"
  29. LIC_FILES_CHKSUM = "file://COPYING;md5=2120be0173469a06ed185b688e0e1ae0"
  30. SECTION = "libs"
  31. SRC_URI = "https://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
  32. SRC_URI[md5sum] = "ead96d240d02faa5b921c0aa50c812b5"
  33. SRC_URI[sha256sum] = "34b8adc726883d0e85b3118fa13605e179a62b31ba51f676136ecb2d0bc1a887"
  34. inherit autotools pkgconfig
  35. BBCLASSEXTEND = "native nativesdk"