powertop_2.10.bb 1.2 KB

12345678910111213141516171819202122232425262728293031323334
  1. SUMMARY = "Power usage tool"
  2. DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
  3. HOMEPAGE = "https://01.org/powertop/"
  4. BUGTRACKER = "https://app.devzing.com/powertopbugs/bugzilla"
  5. DEPENDS = "ncurses libnl pciutils"
  6. LICENSE = "GPLv2"
  7. LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
  8. SRC_URI = "https://01.org/sites/default/files/downloads/powertop-v${PV}.tar.gz \
  9. file://0001-wakeup_xxx.h-include-limits.h.patch \
  10. "
  11. SRC_URI[md5sum] = "a69bd55901cf919cc564187402ea2c9c"
  12. SRC_URI[sha256sum] = "d3b7459eaba7d01c8841dd33a3b4d369416c01e9bd8951b0d88234cf18fe4a75"
  13. UPSTREAM_CHECK_URI = "https://01.org/powertop/downloads"
  14. UPSTREAM_CHECK_REGEX = "powertop-[v]?(?P<pver>\d+(\.\d+)+)\.tar"
  15. inherit autotools gettext pkgconfig
  16. S = "${WORKDIR}/${BPN}-v${PV}"
  17. # we do not want libncursesw if we can
  18. do_configure_prepend() {
  19. # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
  20. sed -i -e "s/ncursesw//g" ${S}/configure.ac
  21. mkdir -p ${B}/src/tuning/
  22. }
  23. inherit update-alternatives
  24. ALTERNATIVE_${PN} = "powertop"
  25. ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
  26. ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
  27. ALTERNATIVE_PRIORITY = "100"