neard_0.16.bb 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. SUMMARY = "Linux NFC daemon"
  2. DESCRIPTION = "A daemon for the Linux Near Field Communication stack"
  3. HOMEPAGE = "http://01.org/linux-nfc"
  4. LICENSE = "GPLv2"
  5. DEPENDS = "dbus glib-2.0 libnl"
  6. SRC_URI = "${KERNELORG_MIRROR}/linux/network/nfc/${BP}.tar.xz \
  7. file://neard.in \
  8. file://Makefile.am-fix-parallel-issue.patch \
  9. file://Makefile.am-do-not-ship-version.h.patch \
  10. file://0001-Add-header-dependency-to-nciattach.o.patch \
  11. "
  12. SRC_URI[md5sum] = "5c691fb7872856dc0d909c298bc8cb41"
  13. SRC_URI[sha256sum] = "eae3b11c541a988ec11ca94b7deab01080cd5b58cfef3ced6ceac9b6e6e65b36"
  14. LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
  15. file://src/near.h;beginline=1;endline=20;md5=358e4deefef251a4761e1ffacc965d13 \
  16. "
  17. inherit autotools pkgconfig systemd update-rc.d
  18. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
  19. PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-systemduserunitdir=${systemd_unitdir}/user/,--disable-systemd"
  20. EXTRA_OECONF += "--enable-tools"
  21. # This would copy neard start-stop shell and test scripts
  22. do_install_append() {
  23. if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
  24. install -d ${D}${sysconfdir}/init.d/
  25. sed "s:@installpath@:${libexecdir}/nfc:" ${WORKDIR}/neard.in \
  26. > ${D}${sysconfdir}/init.d/neard
  27. chmod 0755 ${D}${sysconfdir}/init.d/neard
  28. fi
  29. }
  30. RDEPENDS_${PN} = "dbus"
  31. # Bluez & Wifi are not mandatory except for handover
  32. RRECOMMENDS_${PN} = "\
  33. ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \
  34. ${@bb.utils.contains('DISTRO_FEATURES', 'wifi','wpa-supplicant', '', d)} \
  35. "
  36. INITSCRIPT_NAME = "neard"
  37. INITSCRIPT_PARAMS = "defaults 64"
  38. SYSTEMD_SERVICE_${PN} = "neard.service"