gstreamer1.0_1.18.1.bb 3.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. SUMMARY = "GStreamer 1.0 multimedia framework"
  2. DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
  3. It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
  4. HOMEPAGE = "http://gstreamer.freedesktop.org/"
  5. BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
  6. SECTION = "multimedia"
  7. LICENSE = "LGPLv2+"
  8. DEPENDS = "glib-2.0 glib-2.0-native libxml2 bison-native flex-native"
  9. inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection
  10. LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
  11. file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
  12. S = "${WORKDIR}/gstreamer-${PV}"
  13. SRC_URI = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
  14. file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
  15. file://0002-Remove-unused-valgrind-detection.patch \
  16. file://0003-meson-Add-option-for-installed-tests.patch \
  17. file://0001-gst_private.h-increse-padding-in-struct-_GstClockEnt.patch \
  18. "
  19. SRC_URI[sha256sum] = "79df8de21f284a105a5c1568527f8c559c583c85c0f2bd7bdb5b0372b8beecba"
  20. PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
  21. check \
  22. debug \
  23. tools"
  24. PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false"
  25. PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false"
  26. PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled"
  27. PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled-tests=true,-Dtests=disabled -Dinstalled-tests=false"
  28. PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
  29. PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils"
  30. PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion"
  31. PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled"
  32. PACKAGECONFIG[setcap] = ",,libcap libcap-native"
  33. # TODO: put this in a gettext.bbclass patch
  34. def gettext_oemeson(d):
  35. if d.getVar('USE_NLS') == 'no':
  36. return '-Dnls=disabled'
  37. # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
  38. if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
  39. return '-Dnls=disabled'
  40. return '-Dnls=enabled'
  41. EXTRA_OEMESON += " \
  42. -Ddoc=disabled \
  43. -Dexamples=disabled \
  44. -Ddbghelp=disabled \
  45. ${@gettext_oemeson(d)} \
  46. "
  47. GIR_MESON_ENABLE_FLAG = "enabled"
  48. GIR_MESON_DISABLE_FLAG = "disabled"
  49. PACKAGES += "${PN}-bash-completion"
  50. # Add the core element plugins to the main package
  51. FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
  52. FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
  53. FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
  54. FILES_${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb"
  55. CVE_PRODUCT = "gstreamer"
  56. require gstreamer1.0-ptest.inc