xinput-calibrator_git.bb 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. SUMMARY = "Touchscreen calibration program for X11"
  2. HOMEPAGE = "http://www.freedesktop.org/wiki/Software/xinput_calibrator"
  3. LICENSE = "MIT-X"
  4. LIC_FILES_CHKSUM = "file://src/calibrator.cpp;endline=22;md5=1bcba08f67cdb56f34021557898e4b5a"
  5. DEPENDS = "virtual/libx11 libxi libxrandr"
  6. PV = "0.7.5+git${SRCPV}"
  7. PR = "r6"
  8. inherit autotools pkgconfig features_check
  9. # depends on virtual/libx11
  10. REQUIRED_DISTRO_FEATURES = "x11"
  11. SRCREV = "18ec53f1cada39f905614ebfaffed5c7754ecf46"
  12. SRC_URI = "git://github.com/kreijack/xinput_calibrator.git;branch=libinput \
  13. file://30xinput_calibrate.sh \
  14. file://Allow-xinput_calibrator_pointercal.sh-to-be-run-as-n.patch \
  15. file://0001-calibrator.hh-Include-string-to-get-std-string.patch \
  16. "
  17. S = "${WORKDIR}/git"
  18. # force native X11 ui as we don't have gtk+ in DEPENDS
  19. EXTRA_OECONF += "--with-gui=x11"
  20. do_install_append() {
  21. install -d ${D}${bindir}
  22. install -m 0755 ${S}/scripts/xinput_calibrator_pointercal.sh ${D}${bindir}/xinput_calibrator_once.sh
  23. install -d ${D}${sysconfdir}/X11/Xsession.d/
  24. install -m 0755 ${WORKDIR}/30xinput_calibrate.sh ${D}${sysconfdir}/X11/Xsession.d/
  25. install -d ${D}${sysconfdir}/xdg/autostart
  26. sed -e 's,^Exec=.*,Exec=${bindir}/xinput_calibrator_once.sh,' ${S}/scripts/xinput_calibrator.desktop > ${D}${sysconfdir}/xdg/autostart/xinput_calibrator.desktop
  27. }
  28. FILES_${PN} += "${sysconfdir}/xdg/autostart"
  29. RDEPENDS_${PN} = "xinput formfactor"
  30. RRECOMMENDS_${PN} = "pointercal-xinput"