gio-module-cache.bbclass 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. PACKAGE_WRITE_DEPS += "qemu-native"
  2. inherit qemu
  3. GIO_MODULE_PACKAGES ??= "${PN}"
  4. gio_module_cache_common() {
  5. #if [ "x$D" != "x" ]; then
  6. # $INTERCEPT_DIR/postinst_intercept update_gio_module_cache ${PKG} \
  7. # mlprefix=${MLPREFIX} \
  8. # binprefix=${MLPREFIX} \
  9. # libdir=${libdir} \
  10. # libexecdir=${libexecdir} \
  11. # base_libdir=${base_libdir} \
  12. # bindir=${bindir}
  13. #else
  14. # ${libexecdir}/${MLPREFIX}gio-querymodules ${libdir}/gio/modules/
  15. #fi
  16. echo "dddd"
  17. }
  18. python populate_packages_append () {
  19. packages = d.getVar('GIO_MODULE_PACKAGES').split()
  20. for pkg in packages:
  21. bb.note("adding gio-module-cache postinst and postrm scripts to %s" % pkg)
  22. postinst = d.getVar('pkg_postinst_%s' % pkg)
  23. if not postinst:
  24. postinst = '#!/bin/sh\n'
  25. postinst += d.getVar('gio_module_cache_common')
  26. d.setVar('pkg_postinst_%s' % pkg, postinst)
  27. postrm = d.getVar('pkg_postrm_%s' % pkg)
  28. if not postrm:
  29. postrm = '#!/bin/sh\n'
  30. postrm += d.getVar('gio_module_cache_common')
  31. d.setVar('pkg_postrm_%s' % pkg, postrm)
  32. }