grub_2.04.bb 897 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. require grub2.inc
  2. RDEPENDS_${PN}-common += "${PN}-editenv"
  3. RDEPENDS_${PN} += "${PN}-common"
  4. RDEPENDS_${PN}_class-native = ""
  5. RPROVIDES_${PN}-editenv += "${PN}-efi-editenv"
  6. PROVIDES_append_class-native = " grub-efi-native"
  7. PACKAGES =+ "${PN}-editenv ${PN}-common"
  8. FILES_${PN}-editenv = "${bindir}/grub-editenv"
  9. FILES_${PN}-common = " \
  10. ${bindir} \
  11. ${sysconfdir} \
  12. ${sbindir} \
  13. ${datadir}/grub \
  14. "
  15. FILES_${PN}-common_append_aarch64 = " \
  16. ${libdir}/${BPN} \
  17. "
  18. do_install_append () {
  19. install -d ${D}${sysconfdir}/grub.d
  20. # Remove build host references...
  21. find "${D}" -name modinfo.sh -type f -exec \
  22. sed -i \
  23. -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
  24. -e 's|${DEBUG_PREFIX_MAP}||g' \
  25. -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
  26. {} +
  27. }
  28. INSANE_SKIP_${PN} = "arch"
  29. INSANE_SKIP_${PN}-dbg = "arch"
  30. BBCLASSEXTEND = "native nativesdk"