glide_0.13.3.bb 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. SUMMARY = "Vendor Package Management for Golang"
  2. HOMEPAGE = "https://glide.sh"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=54905cf894f8cc416a92f4fc350c35b2"
  5. GO_IMPORT = "github.com/Masterminds/glide"
  6. SRC_URI = "git://${GO_IMPORT}"
  7. SRCREV = "8ed5b9292379d86c39592a7e6a58eb9c903877cf"
  8. inherit go
  9. # New Go versions has Go modules support enabled by default and cause the Glide
  10. # tool build to fail.
  11. export GO111MODULE = "off"
  12. RDEPENDS_${PN}-dev += "bash"
  13. RDEPENDS_${PN}-ptest += "bash"
  14. BBCLASSEXTEND = "native nativesdk"
  15. # for x86 ends with textrel in ${PN}
  16. # http://errors.yoctoproject.org/Errors/Details/185631/
  17. # ERROR: QA Issue: ELF binary '/work/i586-oe-linux/glide/0.13.1-r0/packages-split/glide/usr/bin/glide' has relocations in .text [textrel]
  18. INSANE_SKIP_${PN} += "textrel"
  19. # for aarch64 ends with textrel in ${PN}-ptest
  20. # http://errors.yoctoproject.org/Errors/Details/185633/
  21. # ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/glide.test' has relocations in .text
  22. # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/dependency/dependency.test' has relocations in .text
  23. # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/repo/repo.test' has relocations in .text
  24. # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/mirrors/mirrors.test' has relocations in .text
  25. # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/cfg/cfg.test' has relocations in .text
  26. # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/godep/strip/strip.test' has relocations in .text
  27. # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/path/path.test' has relocations in .text
  28. # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/tree/tree.test' has relocations in .text
  29. # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/util/util.test' has relocations in .text
  30. # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/action/action.test' has relocations in .text
  31. # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/cache/cache.test' has relocations in .text [textrel]
  32. INSANE_SKIP_${PN}-ptest += "textrel"
  33. # fails to run task compile_ptest_base on mips
  34. PTEST_ENABLED_mipsarch = "0"