cairo_1.16.0.bb 4.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495969798
  1. SUMMARY = "The Cairo 2D vector graphics library"
  2. DESCRIPTION = "Cairo is a multi-platform library providing anti-aliased \
  3. vector-based rendering for multiple target backends. Paths consist \
  4. of line segments and cubic splines and can be rendered at any width \
  5. with various join and cap styles. All colors may be specified with \
  6. optional translucence (opacity/alpha) and combined using the \
  7. extended Porter/Duff compositing algebra as found in the X Render \
  8. Extension."
  9. HOMEPAGE = "http://cairographics.org"
  10. BUGTRACKER = "http://bugs.freedesktop.org"
  11. SECTION = "libs"
  12. LICENSE = "(MPL-1.1 | LGPLv2.1) & GPLv3+"
  13. LICENSE_${PN} = "MPL-1.1 | LGPLv2.1"
  14. LICENSE_${PN}-dev = "MPL-1.1 | LGPLv2.1"
  15. LICENSE_${PN}-doc = "MPL-1.1 | LGPLv2.1"
  16. LICENSE_${PN}-gobject = "MPL-1.1 | LGPLv2.1"
  17. LICENSE_${PN}-script-interpreter = "MPL-1.1 | LGPLv2.1"
  18. LICENSE_${PN}-perf-utils = "GPLv3+"
  19. LIC_FILES_CHKSUM = "file://COPYING;md5=e73e999e0c72b5ac9012424fa157ad77"
  20. DEPENDS = "fontconfig glib-2.0 libpng pixman zlib"
  21. SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.xz \
  22. file://cairo-get_bitmap_surface-bsc1036789-CVE-2017-7475.diff \
  23. file://CVE-2018-19876.patch \
  24. file://CVE-2019-6461.patch \
  25. file://CVE-2019-6462.patch \
  26. "
  27. SRC_URI[md5sum] = "f19e0353828269c22bd72e271243a552"
  28. SRC_URI[sha256sum] = "5e7b29b3f113ef870d1e3ecf8adf21f923396401604bda16d44be45e66052331"
  29. inherit autotools pkgconfig upstream-version-is-even gtk-doc multilib_script
  30. MULTILIB_SCRIPTS = "${PN}-perf-utils:${bindir}/cairo-trace"
  31. X11DEPENDS = "virtual/libx11 libsm libxrender libxext"
  32. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'directfb', d)} \
  33. ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)} \
  34. ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'opengl', '', d)} \
  35. trace"
  36. PACKAGECONFIG_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)}"
  37. PACKAGECONFIG_class-nativesdk = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)}"
  38. PACKAGECONFIG[x11] = "--with-x=yes -enable-xlib,--with-x=no --disable-xlib,${X11DEPENDS}"
  39. PACKAGECONFIG[xcb] = "--enable-xcb,--disable-xcb,libxcb"
  40. PACKAGECONFIG[directfb] = "--enable-directfb=yes,,directfb"
  41. PACKAGECONFIG[valgrind] = "--enable-valgrind=yes,--disable-valgrind,valgrind"
  42. PACKAGECONFIG[egl] = "--enable-egl=yes,--disable-egl,virtual/egl"
  43. PACKAGECONFIG[glesv2] = "--enable-glesv2,--disable-glesv2,virtual/libgles2"
  44. PACKAGECONFIG[opengl] = "--enable-gl,--disable-gl,virtual/libgl"
  45. PACKAGECONFIG[trace] = "--enable-trace,--disable-trace"
  46. EXTRA_OECONF += " \
  47. ${@bb.utils.contains('TARGET_FPU', 'soft', '--disable-some-floating-point', '', d)} \
  48. --enable-tee \
  49. "
  50. # We don't depend on binutils so we need to disable this
  51. export ac_cv_lib_bfd_bfd_openr="no"
  52. # Ensure we don't depend on LZO
  53. export ac_cv_lib_lzo2_lzo2a_decompress="no"
  54. do_install_append () {
  55. rm -rf ${D}${bindir}/cairo-sphinx
  56. rm -rf ${D}${libdir}/cairo/cairo-fdr*
  57. rm -rf ${D}${libdir}/cairo/cairo-sphinx*
  58. rm -rf ${D}${libdir}/cairo/.debug/cairo-fdr*
  59. rm -rf ${D}${libdir}/cairo/.debug/cairo-sphinx*
  60. [ ! -d ${D}${bindir} ] ||
  61. rmdir -p --ignore-fail-on-non-empty ${D}${bindir}
  62. [ ! -d ${D}${libdir}/cairo ] ||
  63. rmdir -p --ignore-fail-on-non-empty ${D}${libdir}/cairo
  64. }
  65. PACKAGES =+ "cairo-gobject cairo-script-interpreter cairo-perf-utils"
  66. SUMMARY_cairo-gobject = "The Cairo library GObject wrapper library"
  67. DESCRIPTION_cairo-gobject = "A GObject wrapper library for the Cairo API."
  68. SUMMARY_cairo-script-interpreter = "The Cairo library script interpreter"
  69. DESCRIPTION_cairo-script-interpreter = "The Cairo script interpreter implements \
  70. CairoScript. CairoScript is used by tracing utilities to enable the ability \
  71. to replay rendering."
  72. DESCRIPTION_cairo-perf-utils = "The Cairo library performance utilities"
  73. FILES_${PN} = "${libdir}/libcairo.so.*"
  74. FILES_${PN}-gobject = "${libdir}/libcairo-gobject.so.*"
  75. FILES_${PN}-script-interpreter = "${libdir}/libcairo-script-interpreter.so.*"
  76. FILES_${PN}-perf-utils = "${bindir}/cairo-trace* ${libdir}/cairo/*.la ${libdir}/cairo/libcairo-trace.so"
  77. BBCLASSEXTEND = "native nativesdk"
  78. UPSTREAM_CHECK_REGEX = "cairo-(?P<pver>\d+(\.\d+)+).tar.xz"