go_1.15.bb 441 B

12345678910111213141516
  1. require go-${PV}.inc
  2. require go-target.inc
  3. inherit linuxloader
  4. export GOBUILDMODE=""
  5. export CGO_ENABLED_riscv64 = ""
  6. export GO_LDSO = "${@get_linuxloader(d)}"
  7. # mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv and its
  8. # variants.
  9. python() {
  10. if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True):
  11. d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel")
  12. }