libxslt_1.1.34.bb 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. SUMMARY = "GNOME XSLT library"
  2. HOMEPAGE = "http://xmlsoft.org/XSLT/"
  3. BUGTRACKER = "https://bugzilla.gnome.org/"
  4. LICENSE = "MIT"
  5. LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
  6. SECTION = "libs"
  7. DEPENDS = "libxml2"
  8. SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz \
  9. "
  10. SRC_URI[md5sum] = "db8765c8d076f1b6caafd9f2542a304a"
  11. SRC_URI[sha256sum] = "98b1bd46d6792925ad2dfe9a87452ea2adebf69dcb9919ffd55bf926a7f93f7f"
  12. UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
  13. S = "${WORKDIR}/libxslt-${PV}"
  14. BINCONFIG = "${bindir}/xslt-config"
  15. inherit autotools pkgconfig binconfig-disabled lib_package multilib_header
  16. do_configure_prepend () {
  17. # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header.
  18. # This can be removed when upgrading to 1.1.34.
  19. sed -i -e 's/ansidecl.h//' ${S}/configure.ac
  20. # The timestamps in the 1.1.28 tarball are messed up causing this file to
  21. # appear out of date. Touch it so that we don't try to regenerate it.
  22. touch ${S}/doc/xsltproc.1
  23. }
  24. EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto --with-html-subdir=${BPN}"
  25. # older versions of this recipe had ${PN}-utils
  26. RPROVIDES_${PN}-bin += "${PN}-utils"
  27. RCONFLICTS_${PN}-bin += "${PN}-utils"
  28. RREPLACES_${PN}-bin += "${PN}-utils"
  29. # This is only needed until libxml can load the relocated catalog itself
  30. do_install_append_class-native () {
  31. create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog
  32. }
  33. do_install_append () {
  34. oe_multilib_header libxslt/xsltconfig.h
  35. }
  36. FILES_${PN} += "${libdir}/libxslt-plugins"
  37. FILES_${PN}-dev += "${libdir}/xsltConf.sh"
  38. BBCLASSEXTEND = "native nativesdk"