wic-image-minimal.bb 605 B

12345678910111213141516171819
  1. SUMMARY = "An example of partitioned image."
  2. SRC_URI = "file://${FILE_DIRNAME}/${BPN}.wks"
  3. IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP}"
  4. IMAGE_FSTYPES = "wic"
  5. DEPENDS = "syslinux syslinux-native dosfstools-native mtools-native gptfdisk-native"
  6. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
  7. # core-image-minimal is referenced in .wks, so we need its rootfs
  8. # to be ready before our rootfs
  9. do_rootfs[depends] += "core-image-minimal:do_image core-image-minimal:do_rootfs_wicenv"
  10. IMAGE_ROOTFS_EXTRA_SPACE = "2000"
  11. inherit image