glib-networking_2.54.1.bb 1.3 KB

1234567891011121314151617181920212223242526272829
  1. SUMMARY = "GLib networking extensions"
  2. DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
  3. HOMEPAGE = "https://gitlab.gnome.org/GNOME/glib-networking/"
  4. BUGTRACKER = "http://bugzilla.gnome.org"
  5. LICENSE = "LGPLv2"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
  7. SECTION = "libs"
  8. DEPENDS = "glib-2.0"
  9. SRC_URI[archive.md5sum] = "99867463f182c2767bce0c74bc9cc981"
  10. SRC_URI[archive.sha256sum] = "eaa787b653015a0de31c928e9a17eb57b4ce23c8cf6f277afaec0d685335012f"
  11. PACKAGECONFIG ??= "ca-certificates gnutls"
  12. # No explicit dependency as it works without ca-certificates installed
  13. PACKAGECONFIG[ca-certificates] = "--with-ca-certificates=${sysconfdir}/ssl/certs/ca-certificates.crt,--without-ca-certificates"
  14. PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
  15. PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy"
  16. PACKAGECONFIG[pkcs11] = "--with-pkcs11,--without-pkcs11,p11-kit"
  17. EXTRA_OECONF = "--without-gnome-proxy"
  18. inherit gnomebase gettext upstream-version-is-even gio-module-cache
  19. FILES_${PN} += "${libdir}/gio/modules/libgio*.so ${datadir}/dbus-1/services/"
  20. FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
  21. FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"