cpio_2.13.bb 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. SUMMARY = "GNU cpio is a program to manage archives of files"
  2. DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \
  3. another. It handles a number of cpio formats as well as reading and writing tar files."
  4. HOMEPAGE = "http://www.gnu.org/software/cpio/"
  5. SECTION = "base"
  6. LICENSE = "GPLv3"
  7. LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
  8. SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \
  9. file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
  10. file://0002-src-global.c-Remove-superfluous-declaration-of-progr.patch \
  11. "
  12. SRC_URI[md5sum] = "389c5452d667c23b5eceb206f5000810"
  13. SRC_URI[sha256sum] = "e87470d9c984317f658567c03bfefb6b0c829ff17dbf6b0de48d71a4c8f3db88"
  14. inherit autotools gettext texinfo
  15. EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
  16. do_install () {
  17. autotools_do_install
  18. if [ "${base_bindir}" != "${bindir}" ]; then
  19. install -d ${D}${base_bindir}/
  20. mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio"
  21. if [ "${sbindir}" != "${bindir}" ]; then
  22. rmdir ${D}${bindir}/
  23. fi
  24. fi
  25. # Avoid conflicts with the version from tar
  26. mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8"
  27. }
  28. PACKAGES =+ "${PN}-rmt"
  29. FILES_${PN}-rmt = "${sbindir}/rmt*"
  30. inherit update-alternatives
  31. ALTERNATIVE_PRIORITY = "100"
  32. ALTERNATIVE_${PN} = "cpio"
  33. ALTERNATIVE_${PN}-rmt = "rmt"
  34. ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
  35. ALTERNATIVE_PRIORITY[rmt] = "50"
  36. ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
  37. BBCLASSEXTEND = "native nativesdk"