matchbox-session-sato_0.1.bb 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. SUMMARY = "Custom Matchbox session files for the Sato environment"
  2. HOMEPAGE = "http://www.matchbox-project.org/"
  3. BUGTRACKER = "http://bugzilla.yoctoproject.org/"
  4. LICENSE = "GPLv2.0+"
  5. LIC_FILES_CHKSUM = "file://session;endline=3;md5=f8a5c5b9c279e52dc094d10e11c2be63"
  6. SECTION = "x11"
  7. RDEPENDS_${PN} = "formfactor matchbox-theme-sato matchbox-panel-2 matchbox-desktop matchbox-session gconf"
  8. PR = "r30"
  9. # This package is architecture specific because the session script is modified
  10. # based on the machine architecture.
  11. PACKAGE_ARCH = "${MACHINE_ARCH}"
  12. inherit features_check
  13. # The matchbox-theme-sato requires x11 in DISTRO_FEATURES
  14. REQUIRED_DISTRO_FEATURES = "x11"
  15. SRC_URI = "file://session \
  16. file://index.theme"
  17. S = "${WORKDIR}"
  18. FILES_${PN} += "${datadir}/themes/Sato/index.theme"
  19. do_install() {
  20. # This is the set of machine features that the script has markers for
  21. FEATURES="acpi apm phone"
  22. SCRIPT="${S}/sedder"
  23. rm -f $SCRIPT
  24. touch $SCRIPT
  25. for FEAT in $FEATURES; do
  26. if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then
  27. echo "/feature-$FEAT/d" >> $SCRIPT
  28. fi
  29. done
  30. install -D ${S}/index.theme ${D}/${datadir}/themes/Sato/index.theme
  31. install -d ${D}/${sysconfdir}/matchbox
  32. sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
  33. chmod +x ${D}/${sysconfdir}/matchbox/session
  34. }
  35. PACKAGE_WRITE_DEPS += "gconf-native"
  36. pkg_postinst_${PN} () {
  37. set_value() {
  38. #type, name, value
  39. gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type $1 --set /desktop/poky/interface/$2 "$3"
  40. }
  41. set_value string theme Adwaita
  42. set_value string matchbox_theme Sato
  43. set_value string icon_theme Sato
  44. set_value bool touchscreen true
  45. set_value string font_name "Sans 9"
  46. }