gstreamer1.0-python_1.16.1.bb 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. SUMMARY = "Python bindings for GStreamer 1.0"
  2. HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
  3. SECTION = "multimedia"
  4. LICENSE = "LGPLv2.1"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
  6. SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
  7. SRC_URI[md5sum] = "499645fbd1790c5845c02a3998dccc1b"
  8. SRC_URI[sha256sum] = "b469c8955126f41b8ce0bf689b7029f182cd305f422b3a8df35b780bd8347489"
  9. DEPENDS = "gstreamer1.0 python3-pygobject"
  10. RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject"
  11. PNREAL = "gst-python"
  12. S = "${WORKDIR}/${PNREAL}-${PV}"
  13. # gobject-introspection is mandatory and cannot be configured
  14. REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
  15. UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
  16. inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection features_check
  17. EXTRA_OECONF += "--with-libpython-dir=${libdir}"
  18. do_install_append() {
  19. # Note that this particular find line is taken from the Debian packaging for
  20. # gst-python1.0.
  21. find "${D}" \
  22. -name '*.pyc' -o \
  23. -name '*.pyo' -o \
  24. -name '*.la' -o \
  25. -name 'libgstpythonplugin*' \
  26. -delete
  27. }