gst-examples_1.16.0.bb 1.3 KB

12345678910111213141516171819202122232425262728293031
  1. SUMMARY = "GStreamer examples (including gtk-play, gst-play)"
  2. LICENSE = "LGPL-2.0+"
  3. LIC_FILES_CHKSUM = "file://playback/player/gtk/gtk-play.c;beginline=1;endline=20;md5=f8c72dae3d36823ec716a9ebcae593b9"
  4. DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gtk+3 glib-2.0-native"
  5. SRC_URI = "git://gitlab.freedesktop.org/gstreamer/gst-examples.git;protocol=https \
  6. file://0001-Make-player-examples-installable.patch \
  7. file://gst-player.desktop \
  8. "
  9. SRCREV = "d953c127c1146b50d5676618299933950685dcd7"
  10. S = "${WORKDIR}/git"
  11. inherit meson pkgconfig features_check
  12. ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
  13. do_install_append() {
  14. install -m 0644 -D ${WORKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop
  15. }
  16. RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback"
  17. RRECOMMENDS_${PN} = "gstreamer1.0-plugins-base-meta \
  18. gstreamer1.0-plugins-good-meta \
  19. gstreamer1.0-plugins-bad-meta \
  20. ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-libav", "", d)} \
  21. ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}"
  22. RPROVIDES_${PN} += "gst-player gst-player-bin"