libxcb_1.13.1.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. SUMMARY = "XCB: The X protocol C binding library"
  2. DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
  3. for Xlib featuring a small footprint, latency hiding, direct access to \
  4. the protocol, improved threading support, and extensibility."
  5. HOMEPAGE = "http://xcb.freedesktop.org"
  6. BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
  7. SECTION = "x11/libs"
  8. LICENSE = "MIT"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
  10. SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \
  11. file://xcbincludedir.patch \
  12. file://disable-check.patch \
  13. "
  14. SRC_URI[md5sum] = "f33cdfc67346f7217a9326c0d8679975"
  15. SRC_URI[sha256sum] = "a89fb7af7a11f43d2ce84a844a4b38df688c092bf4b67683aef179cdf2a647c4"
  16. BBCLASSEXTEND = "native nativesdk"
  17. DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp"
  18. PACKAGES_DYNAMIC = "^libxcb-.*"
  19. FILES_${PN} = "${libdir}/libxcb.so.*"
  20. inherit autotools pkgconfig features_check
  21. # The libxau and others requires x11 in DISTRO_FEATURES
  22. REQUIRED_DISTRO_FEATURES = "x11"
  23. export PYTHON = "python3"
  24. python populate_packages_prepend () {
  25. do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True)
  26. }