waffle_1.6.0.bb 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. SUMMARY = "cross-platform C library to defer selection of GL API and of window system"
  2. LICENSE = "BSD-2-Clause"
  3. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \
  4. file://include/waffle/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf"
  5. SRC_URI = "http://waffle-gl.org/files/release/${BPN}-${PV}/${BPN}-${PV}.tar.xz"
  6. SRC_URI[md5sum] = "61bfc1a478e840825f33ddb4057115e7"
  7. SRC_URI[sha256sum] = "d9c899f710c50cfdd00f5f4cdfeaef0687d8497362239bdde93bed6c909c81d7"
  8. UPSTREAM_CHECK_URI = "http://www.waffle-gl.org/releases.html"
  9. inherit meson features_check lib_package bash-completion
  10. # This should be overridden per-machine to reflect the capabilities of the GL
  11. # stack.
  12. PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glx x11-egl', '', d)} \
  13. ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
  14. surfaceless-egl gbm"
  15. # virtual/libgl requires opengl in DISTRO_FEATURES.
  16. REQUIRED_DISTRO_FEATURES += "${@bb.utils.contains('DEPENDS', 'virtual/${MLPREFIX}libgl', 'opengl', '', d)}"
  17. # I say virtual/libgl, actually wants gl.pc
  18. PACKAGECONFIG[glx] = "-Dglx=enabled,-Dglx=disabled,virtual/${MLPREFIX}libgl libx11"
  19. # I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland
  20. # DISTRO_FEATURE.
  21. PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,virtual/${MLPREFIX}libgl wayland"
  22. # I say virtual/libgl, actually wants gbm.pc egl.pc
  23. PACKAGECONFIG[gbm] = "-Dgbm=enabled,-Dgbm=disabled,virtual/${MLPREFIX}libgl udev"
  24. # I say virtual/libgl, actually wants egl.pc
  25. PACKAGECONFIG[x11-egl] = "-Dx11_egl=enabled,-Dx11_egl=disabled,virtual/${MLPREFIX}libgl libxcb"
  26. PACKAGECONFIG[surfaceless-egl] = "-Dsurfaceless_egl=enabled,-Dsurfaceless_egl=disabled,virtual/${MLPREFIX}libgl"
  27. # TODO: optionally build manpages and examples