pong-clock_1.0.bb 590 B

12345678910111213141516171819202122
  1. SUMMARY = "A clock combined with a game of pong"
  2. LICENSE = "GPLv2+"
  3. DEPENDS = "virtual/libx11 xdmcp xau"
  4. inherit features_check pkgconfig
  5. # depends on virtual/libx11
  6. REQUIRED_DISTRO_FEATURES = "x11"
  7. SRC_URI = "file://pong-clock-no-flicker.c"
  8. LIC_FILES_CHKSUM = "file://pong-clock-no-flicker.c;beginline=1;endline=23;md5=dd248d50f73f746d1ee78586b0b2ebd3"
  9. S = "${WORKDIR}"
  10. do_compile () {
  11. ${CC} ${CFLAGS} ${LDFLAGS} -o pong-clock pong-clock-no-flicker.c `pkg-config --cflags --libs x11 xau xdmcp`
  12. }
  13. do_install () {
  14. install -d ${D}${bindir}
  15. install -m 0755 pong-clock ${D}${bindir}
  16. }