mesa-demos_8.4.0.bb 2.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. SUMMARY = "Mesa demo applications"
  2. DESCRIPTION = "This package includes the demonstration application, such as glxgears. \
  3. These applications can be used for Mesa validation and benchmarking."
  4. HOMEPAGE = "http://mesa3d.org"
  5. BUGTRACKER = "https://bugs.freedesktop.org"
  6. SECTION = "x11"
  7. LICENSE = "MIT & PD"
  8. LIC_FILES_CHKSUM = "file://src/xdemos/glxgears.c;beginline=1;endline=20;md5=914225785450eff644a86c871d3ae00e \
  9. file://src/xdemos/glxdemo.c;beginline=1;endline=8;md5=b01d5ab1aee94d35b7efaa2ef48e1a06"
  10. SRC_URI = "https://mesa.freedesktop.org/archive/demos/${BPN}-${PV}.tar.bz2 \
  11. file://0001-mesa-demos-Add-missing-data-files.patch \
  12. file://0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch \
  13. file://0004-Use-DEMOS_DATA_DIR-to-locate-data-files.patch \
  14. file://0007-Install-few-more-test-programs.patch \
  15. file://0008-glsl-perf-Add-few-missing-.glsl-.vert-.frag-files-to.patch \
  16. file://0009-glsl-perf-Install-.glsl-.vert-.frag-files.patch \
  17. file://0012-mesa-demos-OpenVG-demos-with-single-frame-need-eglSw.patch \
  18. file://0013-only-build-GLX-demos-if-needed.patch \
  19. "
  20. SRC_URI[md5sum] = "6b65a02622765522176d00f553086fa3"
  21. SRC_URI[sha256sum] = "01e99c94a0184e63e796728af89bfac559795fb2a0d6f506fa900455ca5fff7d"
  22. inherit autotools pkgconfig features_check
  23. # depends on virtual/egl, virtual/libgl ...
  24. REQUIRED_DISTRO_FEATURES = "opengl x11"
  25. PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
  26. x11 glew glu glx"
  27. # The Wayland code doesn't work with Wayland 1.0, so disable it for now
  28. #${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
  29. EXTRA_OECONF = "--with-system-data-files"
  30. PACKAGECONFIG[drm] = "--enable-libdrm,--disable-libdrm,libdrm"
  31. PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
  32. PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
  33. PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
  34. PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
  35. PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
  36. PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,freeglut"
  37. PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
  38. PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libopenvg"
  39. PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"
  40. PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11"
  41. PACKAGECONFIG[glew] = "--enable-glew,--disable-glew,glew"
  42. PACKAGECONFIG[glu] = "--enable-glu,--disable-glu,virtual/libgl"
  43. PACKAGECONFIG[glx] = "--enable-glx-demos,--disable-glx-demos"
  44. do_install_append() {
  45. # it can be completely empty when all PACKAGECONFIG options are disabled
  46. rmdir --ignore-fail-on-non-empty ${D}${bindir}
  47. if [ -f ${D}${bindir}/clear ]; then
  48. mv ${D}${bindir}/clear ${D}${bindir}/clear.mesa-demos
  49. fi
  50. }