libva_2.5.0.bb 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. SUMMARY = "Video Acceleration (VA) API for Linux"
  2. DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
  3. and API specification which enables and provides access to graphics \
  4. hardware (GPU) acceleration for video processing on Linux and UNIX \
  5. based operating systems. Accelerated processing includes video \
  6. decoding, video encoding, subpicture blending and rendering. The \
  7. specification was originally designed by Intel for its GMA (Graphics \
  8. Media Accelerator) series of GPU hardware, the API is however not \
  9. limited to GPUs or Intel specific hardware, as other hardware and \
  10. manufacturers can also freely use this API for hardware accelerated \
  11. video decoding."
  12. HOMEPAGE = "https://01.org/linuxmedia/vaapi"
  13. BUGTRACKER = "https://github.com/intel/libva/issues"
  14. SECTION = "x11"
  15. LICENSE = "MIT"
  16. LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
  17. SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2"
  18. SRC_URI[md5sum] = "3688212fb7a87947070f3729e91ff7cf"
  19. SRC_URI[sha256sum] = "3aa89cd369a506ac4dbe5de7c0ef5da4f3d220bf986403f02fa1f6f702af6878"
  20. UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
  21. DEPENDS = "libdrm virtual/mesa"
  22. inherit autotools pkgconfig features_check
  23. REQUIRED_DISTRO_FEATURES = "opengl"
  24. EXTRA_OECONF = "ac_cv_prog_WAYLAND_SCANNER=wayland-scanner"
  25. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
  26. PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
  27. PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"
  28. PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
  29. RDEPENDS_${PN}-x11 =+ "${PN}"
  30. RDEPENDS_${PN}-glx =+ "${PN}-x11"
  31. FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
  32. FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
  33. FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"