libepoxy_1.5.3.bb 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. SUMMARY = "OpenGL function pointer management library"
  2. DESCRIPTION = "It hides the complexity of dlopen(), dlsym(), \
  3. glXGetProcAddress(), eglGetProcAddress(), etc. from the app developer, with \
  4. very little knowledge needed on their part. They get to read GL specs and \
  5. write code using undecorated function names like glCompileShader()."
  6. HOMEPAGE = "https://github.com/anholt/libepoxy/"
  7. SECTION = "libs"
  8. LICENSE = "MIT"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b"
  10. SRC_URI = "https://github.com/anholt/${BPN}/releases/download/${PV}/${BP}.tar.xz \
  11. "
  12. SRC_URI[md5sum] = "e2845de8d2782b2d31c01ae8d7cd4cbb"
  13. SRC_URI[sha256sum] = "002958c5528321edd53440235d3c44e71b5b1e09b9177e8daf677450b6c4433d"
  14. UPSTREAM_CHECK_URI = "https://github.com/anholt/libepoxy/releases"
  15. inherit meson pkgconfig features_check
  16. REQUIRED_DISTRO_FEATURES = "opengl"
  17. REQUIRED_DISTRO_FEATURES_class-native = ""
  18. REQUIRED_DISTRO_FEATURES_class-nativesdk = ""
  19. PACKAGECONFIG[egl] = "-Degl=yes, -Degl=no, virtual/egl"
  20. PACKAGECONFIG[x11] = "-Dglx=yes, -Dglx=no -Dx11=false, virtual/libx11 virtual/libgl"
  21. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} egl"
  22. EXTRA_OEMESON += "-Dtests=false"
  23. PACKAGECONFIG_class-native = "egl x11"
  24. PACKAGECONFIG_class-nativesdk = "egl x11"
  25. BBCLASSEXTEND = "native nativesdk"
  26. # This will ensure that dlopen will attempt only GL libraries provided by host
  27. do_install_append_class-native() {
  28. chrpath --delete ${D}${libdir}/*.so
  29. }
  30. do_install_append_class-nativesdk() {
  31. chrpath --delete ${D}${libdir}/*.so
  32. }