gcr_3.34.0.bb 1.3 KB

1234567891011121314151617181920212223242526272829303132333435
  1. SUMMARY = "A library for bits of crypto UI and parsing etc"
  2. DESCRIPTION = "GCR is a library for displaying certificates, and crypto UI, \
  3. accessing key stores. It also provides the viewer for crypto files on the \
  4. GNOME desktop."
  5. HOMEPAGE = "https://gitlab.gnome.org/GNOME/gcr"
  6. BUGTRACKER = "https://gitlab.gnome.org/GNOME/gcr/issues"
  7. LICENSE = "GPLv2"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
  9. DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt \
  10. ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}"
  11. inherit gnomebase gtk-icon-cache gtk-doc features_check upstream-version-is-even vala gobject-introspection gettext
  12. # depends on gtk+3, but also x11 through gtk+-x11
  13. REQUIRED_DISTRO_FEATURES = "x11"
  14. SRC_URI[archive.md5sum] = "4af28919fb1dd36d93603e8230283b6f"
  15. SRC_URI[archive.sha256sum] = "29df50974a90987af694c0fb8926a6b366e68cacd8abd813817cfe1eb5d54524"
  16. FILES_${PN} += " \
  17. ${datadir}/dbus-1 \
  18. ${datadir}/gcr-3 \
  19. "
  20. # http://errors.yoctoproject.org/Errors/Details/20229/
  21. ARM_INSTRUCTION_SET_armv4 = "arm"
  22. ARM_INSTRUCTION_SET_armv5 = "arm"
  23. ARM_INSTRUCTION_SET_armv6 = "arm"
  24. # These files may be out of date or missing our fixes
  25. # libgcrypt.m4 in particular is calling into libgcrypt-config
  26. do_configure_prepend() {
  27. rm -f ${S}/build/m4/*
  28. }