systemd-bootchart_233.bb 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. LICENSE = "LGPLv2.1 & GPLv2"
  2. LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \
  3. file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe"
  4. SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https \
  5. "
  6. SRC_URI_append_libc-musl = " \
  7. file://0001-comparison_fn_t-is-glibc-specific-use-raw-signature-.patch \
  8. file://0002-musl-does-not-provide-printf-h.patch \
  9. file://0003-musl-does-not-provide-canonicalize_file_name.patch \
  10. "
  11. # Modify these as desired
  12. PV = "233+git${SRCPV}"
  13. SRCREV = "fe1c5e41e6bdb78043dad8fa863fc2df66d1dadf"
  14. S = "${WORKDIR}/git"
  15. DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool"
  16. inherit pkgconfig autotools systemd features_check
  17. REQUIRED_DISTRO_FEATURES = "systemd"
  18. SYSTEMD_SERVICE_${PN} = "systemd-bootchart.service"
  19. do_configure_prepend() {
  20. # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot
  21. rm -f ${S}/m4/intltool.m4
  22. }
  23. FILES_${PN} += "${systemd_unitdir}/systemd-bootchart"
  24. EXTRA_OECONF = " --with-rootprefix=${root_prefix} \
  25. --with-rootlibdir=${base_libdir}"